VCSExpress "The proper type library could not be found in the system registry. [...]" after install

Topics: For MSBee Users
Aug 17, 2006 at 5:21 PM
migrated from power toy forums
originally posted by Alan J. McFarlane
------------------------------------------------------

"The proper type library could not be found in the system registry. ..."

I installed MSBee 1.0 Release.zip and the 1.1 SDK and the next time I ran VS I got that message. I run as restricted user and su'd use Aaron Margolis's MakeMeAdmin.cmd to install both.

To fix it I did MakeMeAdmin and and ran VS from there, after which it ran normally when run normally, as it were.

Was this to be expected?

I'm on XP SP2 with Microsoft Visual C# 2005 Express Edition.

Alan
Aug 17, 2006 at 5:25 PM
originally posted by Bertan Aygun - MSFT
------------------------------------------------------

Did you get the same message as http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=437977&SiteID=1?

It might be that VS needs to add entries to registriy after either SDK 1.1 or MSBee is installed and since you run it under a normal account it was unable to add those entries. Once you run it as admin, those entries are added and everything is normal from there on.

I will try to repro this sceneario to see which one (SDK 1.1 or MSBee) causes this behaviour and we can update the readme for MSBee accordingly.

Thanks,

Bertan
Aug 17, 2006 at 5:25 PM
originally posted by Alan J. McFarlane
------------------------------------------------------

Yup, same message.

Thanks

Alan
Aug 17, 2006 at 5:25 PM
originally posted by Bertan Aygun - MSFT
------------------------------------------------------

I just tried the sceneario. Once you install SDK, the next time you start Visual Studio you have to have admin rights. Same thing does not happen with installing MSBee only if you already have SDK on your machine.

Bertan
Aug 17, 2006 at 5:25 PM
originally posted by Philipp E.
------------------------------------------------------

I had the same problem.
The reset of the access rights of the Registry-Key "HKCR\Interface" (reset child rights too) resolved the Problem.