Updating web references to be 1.1-compatible?

Topics: For MSBee Developers, User Forum
Jan 27, 2011 at 12:24 AM

First, thanks for this great toolkit; it allowed me to rebuild an ancient app in VS2008 for line-of-business machines that only have .Net 1.1.

However, this app uses data from a SOAP web service whose API has recently changed. When I choose Update Web Reference in VS2008, it creates .Net 3.5 reference.cs, which will not build in 1.1.

Is there any way of updating a web reference to be .Net 1.1-compatible in VS2008?

Jan 27, 2011 at 5:55 PM

I was able to get around this problem by saving the original .Net 1.1 Reference.cs file, converting the Web Reference project in VS 2008, updating the web reference, comparing the changes between the converted and updated Reference.cs, then hand-coding the corresponding changes into the original Reference.cs file and replacing the updated file with the hand-coded one.

Obviously, it would be better if this hand-coding were not necessary.